PhoA

Авторское право ©2002-2003 Дмитрий Канн. Все права сохранены.


Назначение программы

В последнее время всё более популярным становится хранение изображений в виде компьютерных файлов. Безусловно, этот способ хранения обладает явными преимуществами по сравнению с хранением "бумажных" фотографий, рисунков и т. д.: электронное изображение не занимает столько места (на обычный записываемый CD-R-диск входит около 5000 фотографий в формате JPEG вполне достойного качества), его легко копировать, показать и даже подарить совсем всем своим и чужим родственникам, друзьям и врагам (последним его можно отправить по электронной почте, так будет даже лучше, если его размер превышает 10-20 мегабайт).

Однако при большом количестве изображений (те же несколько тысяч) их становится крайне трудно найти. Наиболее очевидным и простым способом является раскладывание файлов с изображениями по папкам, соответственно их называя ("Мы с нашей собакой", "Собака без нас" и т. д.), но тут возникает множество неразрешимых противоречий: а как быть, если нужно организовать изображения по датам и одновременно по действующим лицам, по событиям и по местам действий; как связать описание изображения с этим изображением (правда, некоторые программы позволяют вписать текст в сам файл изображения, но уж больно неудобно они это делают); как, наконец, найти из 1287 изображений Вас и Вашей собаки то единственное (и, возможно, последнее), где она прыгает к Вам с пятого этажа?

Все эти нехитрые, казалось бы, задачи и подвигли меня на создание программы для каталогизации: упорядочивания и поиска различных изображений (рисунков, фотографий, скриншотов и всего остального).

Нравится Вам это или нет, но программа получила название PhoA - акроним от словосочетания 'Photo Album', и файлы фотоальбомов, создаваемые программой, также имеют расширение .phoa.

Дальше >>


Как это работает

В основу работы программы положен принцип хранения ссылок на изображения, точнее, на файлы изображений. Поскольку сами изображения хранятся отдельно, их, во-первых, можно легко копировать независимо от программы, во-вторых, просматривать любыми сторонними программами, а в-третьих, не тратится места при копировании ссылки на изображение.

Изображения собираются в группы, а сами группы организовываются иерархически, в виде вложенных папок, в точности, как папки в Проводнике. Группы отображаются в программе в виде папок в левой части окна программы, а входящие в группу изображения - в правой части.

Следует заметить, что группы содержат, опять же, не непосредственные ссылки на изображения. Ссылки на изображения формируют в PhoA некоторый "обменный фонд", общий список изображений, каждый элемент которого содержит данные описания.

Из этого общего списка ссылок составляются группы, то есть группы содержат "ссылки на ссылки на изображения". Тем, кого эти объяснения только запутывают, советую взглянуть на рисунок:

О чём он нам говорит? Он нам говорит о том, что единожды описав изображение на диске, вы можете добавлять его во сколько угодно групп (хоть во все сразу), при этом все эти добавленные изображения в действительности будут иметь лишь одну ссылку на файл и лишь одно описание (дату, место, ключевые слова, описание, эскиз и т. д.).

Дальше >>


Форматы файлов

Как было сказано ранее, программа PhoA работает с файлами фотоальбомов, имеющими расширение .phoa - такой файл содержит в себе:

  • текст описания и параметры фотоальбома;
  • список изображений вместе с их описаниями;
  • иерархию групп-папок, каждая из которых содержит набор ссылок на список изображений фотоальбома.
  • список структур представлений (PhoA версии 1.0.1+).

Файл .phoa недоступен для непосредственного просмотра и открывается только программой PhoA. Начиная с версии программы 1.1.1a возможно также создание собственных инструментов благодаря открытым подробным спецификациям формата PhoA. Более детальная информация находится на сайте программы.

В качестве исходных изображений данная версия программы принимает файлы следующего формата (кликните на кнопке с плюсиком, чтобы развернуть детали):

Стандартные изображения Windows и OS/2 bitmap (*.bmp, *.rle, *.dib)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed, RGB(A)
  • compression formats: uncompressed, RLE

Файлы JPEG (*.jpg; *.jpeg; *.jpe)

  • byte orders: little endian, big endian
  • sample sizes: 8 bits per sample
  • color spaces: grayscale, RGB

Файлы TIFF (*.tif; *.tiff)

  • byte orders: little endian, big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale, RGB(A), CMYK, L*a*b*
  • compression formats: uncompressed, packed bits, LZW, CCITT T.4 (raw and modified fax group 3, possibly word aligned), ThunderScan, Deflate, new style JPEG

Файлы GFI fax (*.fax)

  • sample size: 1 bits per sample
  • color space: indexed
  • compression format: CCITT T.4 (raw and modified fax group 3)

Файлы SGI (*.bw, *.rgb, *.rgba, *.sgi)

  • byte order: big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale, RGB(A)
  • compression formats: uncompressed, RLE

Файлы Autodesk (*.cel; *.pic)

  • byte order: little endian
  • sample size: 8 bits per sample
  • color spaces: indexed
  • compression format: uncompressed

Файлы Truevision Targa (*.tga; *.vst; *.icb; *.vda; *.win)

  • byte order: little endian
  • sample sizes: 5, 8 bits per sample
  • color spaces: gray scale, indexed, 15 bits RGB (555), 24 bits RGB(A)(888)
  • compression formats: uncompressed, RLE

Файлы ZSoft Paintbrush (*.pcx, *.pcc)

  • byte order: little endian
  • sample sizes: 1, 2, 4, 8 bits per sample
  • color spaces: gray scale, indexed, RGB
  • compression formats: uncompressed, RLE

Файлы Word 5.x screen capture (*.scr)

  • byte order: little endian
  • sample sizes: 1, 2, 4, 8 bits per sample
  • color spaces: indexed, gray scaleRGB
  • compression formats: uncompressed, RLE

Файлы Kodak Photo-CD (*.pcd)

  • byte order: little endian
  • samples size: 8 bits per sample
  • color space: YCbCr
  • compression: PCD Huffmann
  • specials:
    • sizes: all resolutions, from 192 x 128 up to 6144 x 4096 (64 Base vaporware)
    • rotated: clockwise and counter-clockwise

Файлы Portable pixel/gray map (*.ppm, *.pgm, *.pbm)

  • byte order: little endian
  • sample sizes: 1, 8 bits per sample
  • color spaces: gray scale, indexed, RGB
  • compression format: uncompressed
  • specials:
    • ASCII and Binary format

Файлы Dr. Halo (*.cut, *.pal)

  • byte order: little endian
  • sample size: 8 bits per sample
  • color spaces: indexed
  • compression formats: RLE
  • specials:
    • external palette file (*.pal) is automatically loaded

Файлы CompuServe GIF (*.gif)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed
  • compression format: LZW
  • specials:
    • interlaced, non-interlaced

Файлы SGI Wavefront (*.rla, *.rpf)

  • byte order: big endian
  • sample size: 8 bits per sample
  • color space: RGB(A)
  • compression formats: RLE

Файлы Photoshop (*.psd, *.pdd)

  • byte order: big endian
  • sample sizes: 1, 8, 16 bits per sample
  • color spaces: indexed, RGB, CMYK, CIE L*a*b*
  • compression formats: uncompressed, packed bits
  • special:
    • duo tone

Файлы Paint Shop Pro (*.psp)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed, gray scale, RGB
  • compression formats: uncompressed, LZ77

Файлы Portable Network Graphic (*.png)

  • byte order: big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale (alpha), RGB(A)
  • compression format: LZ77
  • specials:
    • supported chunks: IHDR, IDAT, IEND, PLTE, gAMA, tRNS, bKGD
    • transparency support partially for RGB, which is stored as 32 bits format

Мощная поддержка форматов изображений реализована благодаря Mike Lischke.

Дальше >>


Эскизы

Максимальный размер эскизов, создаваемых для заносимых изображений, определяется свойствами фотоальбома (то есть каждый фотоальбом может иметь свои настройки размера эскиза) и по умолчанию равен 150х150 пикселов. Если изображение больше этого размера, то эскиз получается путём соответствующего масштабирования картинки.

Хранятся эскизы PhoA всегда в формате JPEG, что обусловлено наиболее эффективным сжатием этого формата. Вы можете контролировать качество получаемых эскизов с помощью настроек программы: чем выше качество эскиза, тем легче по нему узнать исходное изображение, но тем больше он занимает места. Поскольку эскизы сохраняются в файлах фотоальбомов (*.phoa), размеры и качество эскизов напрямую влияют на размер файла фотоальбома и на занимаемый фотоальбомом объём памяти при его открытии.

Дальше >>


Режимы работы программы

Программа PhoA имеет два основных режима работы:

  • обзор и упорядочивание изображений;
  • просмотр изображений.

Эти режимы функционально практически скопированы с одной известной программы (не будем называть фамилии). Ведь зачем изобретать велосипед?

Режим обзора

В этом режиме главное окно программы очень напоминает стандартный Проводник Windows: в левой части расположено дерево групп-папок, а в правой отображаются эскизы и описания изображений, находящихся в выбранной слева группе. В этом режиме Вы можете создавать новые группы в фотоальбоме, добавлять, удалять и изменять изображения в группах, перетаскивать и копировать изображения из одной группы в другую и производить различные сервисные операции.

подробнее >>

Просмотр

Было бы странно, если бы программа для каталогизации изображений не обладала удобным средством их просмотра. В PhoA данный режим позволяет производить просмотр отдельных изображений - исходных, то есть тех, на основе которых построены эскизы в фотоальбоме. При просмотре имеются функции увеличения/уменьшения изображения и прокрутки его на экране, перехода к следующему, предыдущему, первому и последнему изображению в группе, переключения из оконного в полноэкранный режим и обратно.

подробнее >>

Дальше >>


Характеристики и преимущества PhoA

Совершенно несомненно, что PhoA даёт ряд неоспоримых преимуществ при работе с фотографиями, рисунками и прочими воплощениями разных художественных замыслов:

  • Программа не требует установки и (пока) состоит из одного-единственного файла phoa.exe. Что это даёт? Это даёт возможность копировать её вместе с созданным файлом фотоальбома (*.phoa) всюду, где только пожелается. Если положить её на CD-ROM-диск, а в корневой каталог диска поместить соответствующий файл autorun.inf, то Вы сможете демонстрировать Ваши изображения на любом компьютере, просто вставив диск в привод CD-ROM (на компьютерах, где включена функция автозапуска CD-дисков). Программа не обидится, даже если рядом не окажется файла phoa.chm (Справочной системы PhoA).
  • Программа позволяет строить каталоги (называемые фотоальбомами) из совершенно разнородных изображений. Организуются изображения в виде групп-папок наподобие папок в Проводнике Windows. В качестве исходных файлов PhoA принимает практически любые растровые, а также некоторые векторные форматы.
  • Для каждого изображения Вы можете ввести дату, место, номер плёнки и кадра, ключевые слова, описание, автора и пр. Автоматически создаётся эскиз - уменьшенный вариант исходного изображения (поддерживаются несколько вариантов ресэмплинга). Размер эскизов задаётся в параметрах фотоальбома, сами эскизы сохраняются в файле фотоальбома, что позволяет открывать и просматривать фотоальбомы практически мгновенно. Эскизы сжимаются по алгоритму JPEG и могут кэшироваться при просмотре.
  • PhoA позволяет производить мгновенный поиск в созданных фотоальбомах по любым данным: по имени файла, по диапазону дат, по наименованию места, ключевым словам и тексту описания изображения и т. д.; результаты поиска отображаются в виде элемента дерева групп и могут быть слиты с любой группой изображений.
  • В файле фотоальбома сохраняются относительные пути к файлам изображений, поэтому их можно перемещать в любое место, сохраняя неизменным взаимное расположение фотоальбома относительно изображений. Однако в случае, если файл фотоальбома сохранён на другом диске или в сети (или наоборот, изображения находятся на сетевом компьютере, а фотоальбом на локальном), то в фотоальбоме сохраняются абсолютные пути, и тогда его расположение относительно этих изображений не имеет значения.
  • В режиме обзора программа отображает всплывающие описания эскизов. Содержимое этих описаний настраивается.
  • PhoA имеет функции сортировки изображений в выбранной группе или во всём фотоальбоме. Критерии сортировки включают практически все доступные данные, набор для сортировки может состоять из любого количества критериев; последний использованный набор запоминается.
  • Реализованы представления: уникальная технология работы с изображениями в режиме обзора. Вы можете без каких-либо особенных усилий классифицировать изображения, сваленные в общую кучу, по папкам. Единственное условие - свойства изображения должны быть соответствующим образом заполнены. Эти свойства используются для группировки изображений в папки в виде дерева. Возможные варианты группировки изображений: по пути к файлу, по датам и времени в различных вариантах, по месту, ключевым словам и др. Группировки могут быть каскадными, т.е. применяться одна после другой, количество их ограничено только здравым смыслом. Результат группировки (дерево папок вместе с соответствующими изображениями) можно поместить в любую группу фотоальбома, после чего можно доделать полученную ветку по вкусу, как обычно.
  • PhoA обеспечивает просмотр изображений (оконный/полноэкранный режимы), а также удобное отображение их описаний при просмотре. Параметры отображения можно изменить в настройках программы; есть функции просмотра слайдов, масштабирования (увеличения и уменьшения изображения, причём поддерживаются несколько вариантов ресэмплинга) и позиционирования изображения мышью/клавишами. Декодирование изображений осуществляется параллельным потоком и может производиться в фоновом режиме, параллельно с просмотром другого изображения. Также есть функция кэширования предыдущего просмотренного изображения.
  • Программа поддерживает работу с буфером обмена: Вы можете скопировать или вырезать выделенные изображения в буфер, а потом вставить их в другую группу или даже перенести в другой фотоальбом.
  • Имеется полнофункциональная система отката (undo): любая неверная операция может быть отменена (то же сразу для группы операций). Количество запоминаемых операций также устанавливается в настройках.
  • В наличии имеются также прочие сервисные функции (статистика, операции между группами и т. д.)
  • PhoA имеет приятный внешний вид, обходительные манеры и удобный русскоязычный интерфейс. Что ещё нужно правильному пользователю?

Примечание. Формат файла фотоальбома (.phoa) иногда меняется параллельно с развитием программы. Я буду и впредь предпринимать все усилия, чтобы сохранить совместимость "сверху вниз", то есть новые версии программы смогут открывать (и даже сохранять) файлы более старых версий.

Дальше >>


Системные требования

Для установки программы необходимо наличие операционной системы, немного места на диске и чуть-чуть оперативной памяти. Если говорить точнее, то PhoA запускается в среде Windows 95/98/ME/NT/2000/XP, занимает около 2 МБ дискового пространства и требует не менее 16 МБ установленной оперативной памяти. Поскольку в данной версии при открытии фотоальбома он целиком загружается в память, при больших количествах изображений (1000+) желательно наличие адекватного объёма памяти (32-64 МБ для Windows 95/98/ME/NT, 128 МБ для Windows 2000 и XP).

Дальше >>


Данные изображений

Текущая версия PhoA позволяет сохранять, просматривать и изменять (если поле редактируемое) следующие данные для каждого изображения. Кроме того, если поле помечено как поисковое, Вы можете производить поиск по данным этого поля.
Наименование | Тип данных | Редактируемое | Поисковое | Описание
ID | Натуральное число | Нет | Да | Уникальный внутренний идентификатор изображения. В фотоальбоме однозначно сопоставлен с именем файла. Используется для идентификации изображения, а также для создания ссылок.
Имя файла изображения | Строка-имя файла | Нет | Да | Имя файла изображения (без пути)
Полное имя файла изображения | Строка-имя файла | Нет | Нет | Имя файла изображения вместе с путём. Полное имя файла изображения уникально среди всех изображений фотоальбома.
Путь к файлу изображения | Строка | Нет | Да | Часть полного имени файла изображения, представляющая собой путь к этому файлу.
Размер файла изображения | Строка | Нет | Нет | "Человекочитаемое" представление размера файла изображения, например, 212,45 Кбайт или 839 байт.
Размер файла изображения в байтах | Целое число | Нет | Да | Целочисленное представление размера файла изображения, выраженное в байтах, например, 678233.
Ширина изображения | Целое число | Нет | Да | Ширина изображения, выраженная в пикселах.
Высота изображения | Целое число | Нет | Да | Высота изображения, выраженная в пикселах.
Размеры изображения | Строка | Нет | Нет | Размеры изображения в пикселах в виде Ширина x Высота, например, 1024x768.
Формат изображения | Пиксельный формат | Нет | Нет | Пиксельный формат изображения, например, 1 бит (монохромное) или Определяется устройством.
Дата | Дата | Да | Да | Дата событий на изображении, в диапазоне от 1 января 0001 г. до 31 декабря 9999 г. (вот бы дожить). Даты до нашей эры не поддерживаются.
Время | Время | Да | Да | Время событий на изображении, в диапазоне от 00:00:01 (значение, равное 00:00:00, считается отсутствием значения) до 23:59:59.
Место | Строка | Да | Да | Место, запечатлённое на изображении.
Номер или название плёнки | Строка | Да | Да | Если изображение снято плёночным фотоаппаратом, номер плёнки, содержащей изображение, присвоенный ей при проявке (обычно уникален), или присвоенное Вами название плёнки.
Номер кадра | Строка | Да | Да | Если изображение снято плёночным фотоаппаратом, номер кадра изображения, например, 20 или 4A.
Автор | Строка | Да | Да | Имя автора изображения или фотографа, сделавшего снимок.
Наименование или код носителя | Строка | Да | Да | Название носителя, на котором записан файл изображения (например, номер CD-ROM-диска).
Ключевые слова | Список строк | Да | Да | Список ключевых слов, связанных с изображением - например, люди или предметы на фотографии. Всегда отсортирован по алфавиту, сравнение ключевых слов всегда регистронезависимо.
Описание | Строка | Да | Да | Более-менее краткое описание событий на изображении, предназначенное для отображения при просмотре (это рекомендуемое назначение поля).
Примечания | Строка | Да | Да | Любые данные, не попавшие в остальные поля.

См. также:

Режим обзора
Работа в режиме обзора
Поиск изображений
Окно свойств изображений


Ресэмплинг

Изображения часто выглядят "мохнатыми" после масштабирования в другой размер. "Мохнатость" изображения определяется двумя процессами: ресэмплингом и фильтрацией.

Процесс фильтрации делает попытку смягчить (размыть) преобразуемые пикселы. Когда изображение подвергается ресэмплингу в другой размер, возникает необходимость в интерполяции старой сетки пискселов в новую. Эта интерполяция может быть выполнена несколькими методами. Самый простой и быстрый метод - метод функции "ближайшего соседа" (nearest neighbor). При небольших изменениях размеров изображения этого метода вполне достаточно. Однако при большом увеличении картинки пикселы превращаются в большие квадраты; при сильном уменьшении возникает эффект антиалиасинга, который и проявляется в "мохнатости" изображения. В таких случаях можно использовать более точные методы интерполяции, которые, однако, требуют больше времени на обработку изображения. Наиболее часто используемые интерполяционные фильтры - это nearest neighbor, билинейный и B-сплайновый (в порядке возрастания точности). Полный список реализованных в PhoA фильтров таков:

  • Nearest neighbor (метод "ближайшего соседа");
  • Linear (билинейная интерполяция);
  • B-spline (B-сплайн или бикубическая интерполяция);
  • Lanczos;
  • Mitchell.


Метаданные

Файлы изображений могут содержать кроме собственно графической информации дополнительные (текстовые) данные, называемые метаданными. Такие метаданные, например, помещаются в изображения практически всеми цифровыми фотоаппаратами, и содержат, чаще всего, информацию о дате и времени съёмки, данные об условиях съёмки (ориентацию камеры, использование вспышки, фокусное расстояние и экспозиция) и т. д.

Впоследствии эти данные могут быть просмотрены и даже изменены некоторыми программами, а в целом они представляют собой достоверный и ценный источник информации об изображении, к тому же содержащийся непосредственно в его файле и всегда его сопровождающий.

NB: Значительной и не вполне очевидной проблемой является то, что изображения открываются практически любыми программами, независимо от того, содержатся в них метаданные или нет, а также от того, поддерживают ли эти программы вообще метаданные или нет - формат файла изображения это позволяет. Подвох состоит в том, что вы можете открыть изображение какой-нибудь не очень умной программой просто для того, чтобы, скажем, развернуть изображение на 90°, и сохранить его. Если эта программа не поддерживает метаданных, то вы просто потеряете их, переписав файл. Не пользуйтесь глупыми программами!

Начиная с версии 1.1.1a, PhoA тоже резко поумнел, и теперь программа поддерживает метаданные в спецификации EXIF 2.1 - формат метаданных для файлов JPEG. Считанные метаданные могут быть просмотрены, а также могут быть использованы для автозаполнения свойств изображений (при соответствующей настройке).

Кроме того, чтобы поспособствовать появлению умных и образованных программ (хотя бы написанных на Delphi), я решил опубликовать на сайте PhoA исходные коды модуля, осуществляющего чтение метаданных.


История версий

Этот документ суммирует отличия между версиями PhoA в обратном хронологическом порядке.

PhoA 1.1.1b

[17.09.2003]

  • Новые опции Поиск при наборе текста и Задержка сброса набора для поиска в настройках деревьев/списков.
  • В диалоге Свойства изображений фокусируется первый элемент на странице.
  • Изменения на странице Свойства изображений | Метаданные: панель описания, вывод кода метатега.
  • Изменения на странице Свойства изображений | Просмотр: исправлено масштабирование колёсиком мыши.
  • Изменения на странице Свойства изображений | Ключевые слова: переключатель Только отмеченные; новые ключевые красятся в синий цвет только при отсутствии выделения.
  • Изменения на странице Свойства изображений | Группы: ускорено первое отображение страницы.
  • Сделана попытка исправить отображение шрифтов и в Unicode-, и в не-Unicode-системах для разных кодовых страниц/наборов символов.
  • Изменены диалоги, исправлено отображение в системах, где используются крупные шрифты.
  • Немного расширен список EXIF-метатегов, добавлены описания ко многим тегам.
  • Введена поддержка "нестандартных" метатегов: Unicode (WinXP-тегов), версий и т.д.
  • Исправлена ошибка загрузки, проявлявшаяся в отказе PhoA читать фотоальбомы версии 0.x.
  • Исправлена ошибка при просмотре: предекодирование не работало.
  • Исправлена ошибка при поиске: неверно работал поиск по дате, времени и ключевым словам.
  • Устранена некоторая утечка памяти, возникавшая в процессе работы.

PhoA 1.1.1a

[08.09.2003]

  • Изменён формат файла фотоальбома - теперь он весьма расширяем и предполагается, что будет меняться не так часто.
  • Немного изменён вид и работа с деревом папок:
    • Убрана панель инструментов "Представления", вместо неё появилась кнопка быстрого вызова меню представлений рядом с узлом фотоальбома.
    • Изображения можно складывать непосредственно в узел фотоальбома, даже не создавая ни одной группы.
    • Рядом с именем группы-папки отображается количество изображений в группе.
    • Изменён принцип работы механизма Drag'n'Drop: для вставки узла "братом" другого узла (выше или ниже), необходимо перетащить узел на свободное место, при этом место вставки отображается горизонтальной линией. Чтобы сделать узел "ребёнком" другого узла, его нужно перетащить непосредственно на этот узел, при этом подсвечивается сам целевой узел. Кнопка Shift ушла в историю (в смысле, в дереве папок ;)
    • При перетаскивании группы или изображений на узел группы-папки этот узел раскрывается, если задержать на нём мышь на некоторое время. Также при остановке мыши вблизи верхней или нижней границы окна групп (при перетаскивании) дерево групп начинает прокручиваться.
    • Косметические изменения (корневые элементы выделяются жирным шрифтом, при Drag'n'Drop перетаскивается "фантомное" изображение папок и т.д.)
    • Списки можно настраивать.
  • Полностью разделены процессы добавления и редактирования изображений. Сделано это с целью убрать компромиссные решения в интерфейсе программы. Изображения добавляются всегда с параметрами по умолчанию, потом при желании можно заполнить их данные.
  • Изменения в окне добавления изображений:
    • Окно выполнено в виде мастера, при этом на первом этапе выбираются файлы и/или папки с изображениями, на втором можно выбрать уже индивидуальные файлы.
    • При выборе изображений можно отфильтровать их по наличию/отсутствию в фотоальбоме, по формату и дате/времени модификации файла.
    • Добавление изображений производится в отдельном потоке, что улучшило реакцию интерфейса на действия пользователя. Процесс добавления может быть временно приостановлен.
    • Процесс добавления протоколируется, протокол может быть сохранён в файл.
  • Полнофункциональная поддержка спецификации метаданных JPEG-изображений EXIF 2.1 - сведений, помещаемых в изображения практически любой цифровой камерой, а также современными графическими редакторами. Метаданные могут быть использованы для заполнения отдельных полей данных изображения.
  • В окне свойств изображений изменений столько, что проще показать, чем рассказать :). Кратко:
    • Диалог стал многостраничным.
    • Страница Свойства файла позволяет просмотреть информацию о файлах, предоставляемую Windows.
    • Страница Метаданные отображает все данные EXIF, содержащиеся в файлах JPEG.
    • Страница Просмотр даёт возможность просмотреть любой из выбранных файлов в выбранном масштабе.
    • Страница Данные - это, собственно, то, что и было раньше диалогом свойств изображения + возможность ввода новых данных.
    • Страница Ключевые слова позволяет изменять список ключевых слов добавляя, удаляя или изменяя заданное слово во всех выбранных изображениях.
    • Страница Группы отображает список групп фотоальбома, и помечает те, к которым принадлежат выбранные изображения. Можно внести эти изображения в группу или удалить их из группы, поставив или сняв отметку с её имени.
  • Сильно расширены настройки программы.
  • Можно переставлять изображения внутри группы с помощью Drag'n'Drop (в окне просмотра эскизов). Ранее порядок можно было изменить только сортировкой.
  • Представления теперь поддерживают автоматическую сортировку изображений в группе.
  • В окне просмотра эскизов всегда по возможности выделяется первый эскиз.
  • Убрано окно истории операций: требуемое количество операций может быть отменено непосредственным выбором из списка кнопки Отменить на панели инструментов или через подменю Правка | История изменений.
  • Изменены все прочие деревья, отображавшие список групп. Их вид приведён в соответствие главному дереву.
  • В строке состояния (status bar) отображается общее количество различных изображений в фотоальбоме.
  • В режиме просмотра отображается локальная панель инструментов.
  • Панели инструментов и окно просмотра эскизов в Windows XP и более поздних имеют более XP-шный вид.
  • Моря исправлений, океаны мелких изменений, горстка новых багов.

PhoA 1.0.2a

[02.06.2003]

  • По многочисленным жалобам на качество эскизов введена фильтрация при ресэмплинге для устранения "мохнатости" (fuzziness) уменьшенного изображения. Возможные варианты фильтрации: Nearest Neighbor, Linear, B-spline (бикубическая), Lanczos, Mitchell. В качестве побочного эффекта, вследствие сглаживания картинки эскиза, размер эскизов (так как используется JPEG-сжатие) уменьшается на 10-25% (так, при использовании B-сплайн-интерполяции уменьшение составляет 20-25%).
  • Значительно увеличена скорость масштабирования и прокрутки изображения. При просмотре можно также применять любой из вышеперечисленных фильтров.
  • Добавлена опция декодирования изображений в фоновом режиме: отдельный поток декодирует следующее изображение, пока Вы просматриваете текущее. В таком варианте время перехода к следующему изображению минимально (но требует больше памяти).
  • Добавлена опция кэширования просмотренного изображения, что минимизирует время возврата к предыдущему изображению (также требует больше памяти).
  • По ошибке поддержка формата .gif не была включена. Исправлено.
  • Добавлена поддержка форматов .msk (Paint Shop Pro mask), .tub (Paint Shop Pro picture tube), .pfr (Paint Shop Pro picture frame).
  • Кардинально изменен вывод информации при просмотре. Теперь информация всегда выводится поверх изображения, опционально на полупрозрачном фоне, есть режим визуального позиционирования блока информации.
  • В системах с несколькими мониторами диалоговые окна открывались в неподходящих местах. Исправлено.

PhoA 1.0.1a

[17.05.2003]

Огромное множество изменений, что отражается в номере версии и времени, затраченном на её создание.

  • Представления! [начинается... :] Принципиально новый алгоритм работы с изображениями в режиме обзора. Теперь Вы можете без каких-либо особенных усилий классифицировать изображения, сваленные в общую кучу, по папкам. Единственное условие - свойства изображения должны быть соответствующим образом заполнены. Возможные варианты группировки изображений: по пути к файлу, по датам в различных вариантах, по месту, ключевым словам и др. Группировки могут быть каскадными, т.е. применяться одна после другой, количество их ограничено только здравым смыслом. Результат группировки (дерево папок вместе с соответствующими изображениями) можно поместить в любую группу фотоальбома, после чего можно доделать полученную ветку по вкусу, как обычно.
  • Изменён формат файла фотоальбома (.phoa). Файлы фотоальбомов, начиная с версии 1.0.1a, содержат данные о представлениях, и это делает их несовместимыми с более старыми версиями PhoA. Программа поддерживает сохранение также и в файлы формата PhoA 0.x, что выбирается при сохранении файла (Файл | Сохранить как...), соответственно, представления при этом не сохраняются.
  • Сортировка теперь может состоять из любого количества критериев, и она построена аналогично группировкам в представлении. Список признаков для сортировки теперь существенно расширен.
  • Всплывающие описания эскизов в режиме просмотра теперь можно настраивать, выбирая, какие именно данные в них приводятся.
  • Информация об изображении, отображаемая в режиме просмотра, теперь тоже пополнилась дополнительными вариантами выбора.
  • Три варианта размеров кнопок панели инструментов (мелкие/средние/крупные).
  • Глобально расширена поддержка форматов. Теперь поддерживается почти всё, что можно (кратко: Windows bitmap (BMP, RLE, DIB), OS/2 bitmap, TIFF, GFI fax, SGI, Autodesk, Truevision Targa, ZSoft Paintbrush, Word 5.x, Kodak Photo-CD, Portable pixel/gray map, Dr. Halo CUT, CompuServe GIF, SGI Wavefront, Photoshop, Paint Shop Pro, Portable network graphic PNG; подробнее см. там, где рассказывается о форматах)
  • Новые алгоритмы работы с ключевыми словами (ключевые слова, содержащие пробелы и запятые, должны браться в кавычки; при выборе из списка такие ключевые слова берутся в кавычки автоматически; убрано преобразование ключевых слов в нижний регистр при построении их списка, но сравнение ключевых слов по-прежнему регистронезависимо).
  • Куча мелких исправлений (в т.ч. исправлен Access Violation в некоторых случаях в режиме обзора).

PhoA 0.10 beta

[01.09.2003]

  • PhoA теперь имеет полностью функциональную систему отката (undo).
  • Сделана кнопка "Добавить все" в Окне добавления изображения, позволяющая произвести добавление в группу всех выбранных файлов изображений без запроса пользователя (с параметрами по умолчанию).
  • Добавлена работа с буфером обмена (вырезать, копировать, вставить).
  • Мелкие исправления (режим обзора; статистика фотоальбома).

PhoA 0.03

[20.10.2002]

  • Полностью двуязычная версия (русский и английский языки), в том числе Программа установки и файлы Справочной Системы.
  • Реализован режим Показа слайдов.
  • Мелкие исправления.

PhoA 0.02b

[06.09.2002]

  • Первый общедоступный релиз программы.


Лицензионное соглашение

English version of License Agreement >>

Если обратное не указано явно, авторские права на всю документацию и программное обеспечение, включённые в состав продукта PhoA, принадлежат Дмитрию Канну.

Авторское право ©2002-2003 Дмитрий Канн. Все права сохранены.

Это программное обеспечение поставляется по принципу "as-is", без каких-либо явных или подразумеваемых гарантий. Ни при каких обстоятельствах автор не может нести ответственности за любые повреждения, возникшие по причине использования этого программного обеспечения.

Допускается свободно использовать это программное обеспечение для любой цели, в том числе для коммерческих применений, а также изменять и распространять его на вторичной основе при соблюдении следующих условий:

  1. Любое вторичное распространение продукта и его файлов должно сохранять все данные об авторском праве, имеющиеся на данный момент, а также этот список условий без каких-либо изменений.
  2. Все новые инсталляции, полученные в результате перевода ресурсов PhoA на любой язык в виде бинарных файлов должны сохранять все вхождения упомянутых авторских знаков и ссылок на сайты в Интернет, которые присутствуют в настоящее время (например, в окне "О программе").
  3. Происхождение данного продукта не должно искажаться; кроме того, при использовании программного обеспечения в поставке функционального продукта упоминание в документации об оригинальном источнике ПО категорически приветствуется.
  4. Модифицированные версии должны быть недвусмысленно помечены, как таковые, а не должны прикидываться оригинальным продуктом.

Обновления: http://phoa.narod.ru
Контактный адрес: phoa@narod.ru

Благодарности

  • Jordan Russel - Toolbar2000
  • Alex Denisov - TBX & Graphics32
  • Mike Lischke - GraphicEx & VirtualTreeview
  • Jim Kueneman - VirtualShellTools


Режимы работы программы

Программа PhoA имеет два основных режима работы:

  • обзор и упорядочивание изображений;
  • просмотр изображений.


Режим обзора

Как уже было сказано, режим обзора предназначен для создания фотоальбома. Этот режим является стартовым для программы - запускается PhoA именно в этом режиме.

Главное окно программы построено по принципу стандартного Проводника Windows: в левой части расположено дерево групп-папок, а в правой отображаются эскизы и описания изображений, находящихся в выбранной слева группе.

Слева у корневого узла дерева - узла фотоальбома расположена кнопка-меню, содержащая команды работы с представлениями фотоальбома и переключения отображения между представлениями и группами фотоальбома.

См. также:

Описание команд меню
Работа в режиме обзора
Работа с представлениями


Описание команд меню в режиме обзора

Меню "Файл"

В этом меню собраны команды работы с файлами фотоальбомов:

  • Создание нового фотоальбома происходит автоматически при запуске программы или при выборе пункта меню Файл | Новый. При этом удаляются все группы и изображения, а параметры фотоальбома приводятся к заданным по умолчанию.
  • Чтобы открыть ранее сохранённый файл фотоальбома, нужно выбрать пункт меню Файл | Открыть.... Это вызовет диалог открытия файла фотоальбома (с расширением .phoa).
  • Для сохранения файла фотоальбома с текущим именем выбирается пункт Файл | Сохранить.
  • Для сохранения в другой файл - пункт Файл | Сохранить как....
  • Пункт меню Файл | Выход запрашивает подтверждение в случае несохранённого фотоальбома и завершает работу с программой.
  • Далее следуют пункты меню последних открывавшихся файлов (их количество настраивается с помощью Окна настроек программы).

Меню "Правка"

Здесь собраны команды для редактирования фотоальбома:

  • Пункт меню Правка | Отменить имя_операции отменяет изменения, сделанные Вами при выполнении указанной (последней) операции.
  • Подменю Правка | История изменений предоставляет доступ к списку сделанных изменений, с помощью которого Вы можете отменить несколько сделанных операций сразу.
  • Пункт меню Правка | Вырезать удаляет выделенные изображения в буфер обмена (вы можете впоследствии вставить их в другую группу).
  • Пункт меню Правка | Копировать, аналогично, копирует выделенные изображения в буфер обмена.
  • Пункт Правка | Вставить позволяет добавить изображения из буфера обмена в текущую группу, если они там есть. Естественно, добавляются только изображения, новые для текущей группы - совпадающие изображения отсеиваются. Если это указано в настройках программы, выводится уведомление о количестве реально вставленных изображений.
  • На вершине иерархии папок находится фотоальбом - он является корневым узлом дерева. Для него можно ввести описание и изменить параметры эскизов в окне свойств фотоальбома - делается это выбором пункта меню Правка | Изменить..., когда узел фотоальбома выделен.
  • Группу можно переименовать, выбрав пункт меню Правка | Изменить..., когда группа выделена в дереве, или нажав один раз на выделенном наименовании группы, или с помощью клавиши F2. После этого для отмены редактирования нужно нажать клавишу Esc, для сохранения нового имени группы - клавишу Enter.
  • Добавление новой группы осуществляется выбором пункта меню Правка | Добавить группу. При этом в дереве создаётся новая папка группы - в текущей выделенной папке. Если выделен узел фотоальбома, то группа будет создана в корневом каталоге альбома. По умолчанию группе даётся имя "Новая группа", которое нужно изменить и нажать клавишу Enter.
  • Удаление группы производится выбором пункта меню Правка | Удалить, когда активно дерево папок.
  • Чтобы добавить изображения в группу, необходимо выбрать пункт меню Правка | Добавить изображение..., при этом откроется окно Мастера добавления изображений.
  • Для упорядочивания изображений пункт меню Правка | Сортировать изображения... предоставляет доступ к окну сортировки изображений.
  • Пункт меню Правка | Выделить все выделяет все изображения текущей группы.
  • Пункт Правка | Снять выделение наоборот, убирает выделение со всех изображений группы.
  • Для перехода в режим просмотра нужно выбрать пункт меню Правка | Просмотр или сделать двойной щелчок мышью на изображении.

Меню "Вид"

Это меню контролирует отображение элементов программы и представления:

  • Показ панели инструментов (Вид | Панель инструментов) и
  • Показ строки состояния (Вид | Строка состояния). Программа запоминает состояние этих пунктов и восстанавливает при следующем запуске.
  • Далее следуют пункты для работы с представлениями фотоальбома:
    • Пункт Группы изображений служит для перехода к основному режиму просмотра дерева папок, когда в левом окне программы отображаются группы фотоальбома (режим по умолчанию).
    • Пункт Новое представление... открывает окно свойств для создания нового представления.
    • Пункт Удалить представление удаляет текущее представление (если в данный момент активно именно представление).
    • Пункт Изменить представление... открывает окно свойств для редактирования текущего представления (если в данный момент активно именно представление).
    • Пункт Поместить в группу... вызывает диалоговое окно выбора группы фотоальбома, позволяющее создать копию папок представления в группах фотоальбома.

Меню "Сервис"

Здесь расположены дополнительные инструменты для работы с фотоальбомами:

  • Пункт Сервис | Настройки программы... отображает окно настроек режима обзора PhoA.
  • Пункт Сервис | Статистика... подсчитывает и выводит различные сводные данные по фотоальбому.
  • Пункт Сервис | Перестроить эскизы... отображает окно перестройки эскизов, позволяющее выполнить пересоздание эскизов для выбранных изображений, для текущей группы или всего фотоальбома. Эта операция должна выполняться каждый раз, когда Вы меняете параметры эскизов в окне свойств фотоальбома.
  • Пункт Сервис | Операции с изображениями... позволяет выполнять перемещение, копирование и другие операции с изображениями.
  • Одной из самых важных функций PhoA является поиск, окно которого вызывается выбором пункта Сервис | Поиск.... Более подробно о поиске рассказано здесь.

Меню "Справка"

Меню состоит из трёх пунктов:

  • Пункт Справка | О программе... вызывает окно с информацией о версии программы, об авторских правах и координатах для поиска обновлённых версий.
  • Пункт Справка | Содержание справки запускает Справочную систему PhoA, которую Вы в данный момент и наблюдаете.
  • Пункт Справка | Web-сайт программы запускает Интернет-браузер по умолчанию и открывает в нём домашнюю страницу PhoA.

Непосредственно слева от узла фотоальбома в дереве папок расположена кнопка, вызывающая меню представлений.

См. также:

Сочетания клавиш и управление мышью
Режим просмотра
Окно свойств фотоальбома


Работа в режиме обзора

О наиболее общих задачах работы в режиме обзора упомянуто в рассказе о командах меню. Здесь я остановлюсь на более специфических вопросах работы с программой.

Данные изображений

Как уже было сказано в лирической части, программа хранит отдельно список изображений (точнее, список, элементы которого содержат ссылки на файлы изображений, эскизы, то есть уменьшенные копии исходных изображений, описания и т. д.). Как отдельный класс хранится дерево групп. Каждая отдельная группа содержит ссылки на этот список изображений, поэтому когда Вы добавляете к группе файл (а работа с изображениями всё равно ведётся на уровне файлов), который уже используется в фотоальбоме, программа сама подставляет все данные изображения; аналогично, если Вы изменяете какие-то данные изображения (например, место или дату), эти данные меняются и во всех вхождениях данного файла в группы фотоальбома.

Немного иначе работает этот принцип при удалении изображения из группы. Если на удаляемое изображение ссылается кроме текущей ещё и другая группа (или группы), то удаляется только ссылка на него, а само изображение продолжает "числиться" в фотоальбоме (ведь на него ссылаются другие группы); и если, скажем, вы будете потом добавлять этот файл опять, PhoA подставит все данные из найденного изображения. Если же это изображение присутствовало только в текущей группе, и оно удаляется - то оно будет стёрто из фотоальбома совсем, и при повторном добавлении Вам опять придётся вносить все данные этого изображения.

Drag'n'Drop

Естественно, одно изображение не может дважды входить в одну и ту же группу. Наиболее простой способ копирования изображений состоит в перетаскивании их мышью из правой части окна PhoA (эскизов) в левую (дерево папок), удерживая нажатой клавишу Ctrl. Если Вы перетаскиваете изображение без клавиши Ctrl, то изображение будет перемещено (удалено из исходной группы и помещено в группу назначения). Можно перетаскивать более, чем одно изображение одновременно: для этого перед началом перетаскивания нужно выделить все нужные изображения (с помощью клавиш Ctrl, Shift, Alt и нажатия левой кнопки/сдвига мыши) и начинать перетаскивание с любого из выделенных изображений. После завершения операции копирования/перемещения изображений PhoA выдаёт сводную информацию о сделанных изменениях, если это указано в Настройках программы (раздел Уведомления).

Помимо этого, можно перетаскиванием изменять структуру групп в их дереве. При перетаскивании группы на свободное пространство справа от узлов отображается место вставки группы в виде линии, при этом группа вставляется "братом" целевого узла, выше или ниже его, в зависимости от положения курсора мыши (также отражается на форме линии вставки). При перетаскивании группы поверх какого-либо узла, узел подсвечивается, и группа становится дочерним узлом подсвеченного узла. Примечание: в корневом каталоге может находится только узел фотоальбома, обычные группы не могут быть вставлены рядом с ним.

Совершенно аналогичным образом можно копировать (перемещать тут нельзя) изображения из узла результатов поиска в любую группу. Поэтому удобно, например, после составления каталога фотографий по событиям, выбрать их по датам (например за год или за месяц) и организовать в папки по времени (или по месту).

Кроме всего вышеперечисленного, с помощью перетаскивания можно менять порядок следования изображений в группе: при перетаскивании выделенных эскизов внутри окна просмотра эскизов, также отображается место их вставки. Если отпустить кнопку мыши, все выделенные изображения переместятся в выбранное место в последовательности изображений, сохранив внутренний порядок (последовательность в которой они находились до перетаскивания). Альтернативный метод упорядочивания изображений - это их сортировка.

Буфер обмена

PhoA поддерживает работу с буфером обмена. На данный момент Вы можете вырезать, копировать и вставлять только изображения формата самой программы. Данные, помещаемые в буфер, содержат всю информацию, касающуюся выделенных изображений, кроме их принадлежности группам. Это позволяет переносить (копировать) изображения в другую группу или даже в другой фотоальбом.

Есть одно ограничение, касающееся вставки изображений в другой фотоальбом: данные существующих (зарегистрированных в фотоальбоме с этим же именем файла) изображений не переписываются новыми; то есть при вставке, скажем, изображения, связанного с файлом C:\Photos\winter-vacation-1812.jpg, в фотоальбом, где этот файл уже зарегистрирован, это изображение просто будет добавлено в текущую группу (если его там ещё не было). В случае наличия вставляемого из буфера обмена изображения в целевой группе это изображение просто пропускается. По завершении вставки программа уведомляет Вас о количестве реально добавленных из буфера обмена изображений (контролируется Настройками программы - раздел Уведомления).

Система отката

В отличие от многих аналогов, PhoA имеет полнофункциональную систему отката (undo), позволяющую отменить результаты выполнения любой операции, изменившей данные фотоальбома (исключение составляет только операция перестройки эскизов), а также серии операций - путём выбора команды меню Правка | Отменить или Правка | История изменений соответственно. При выборе пункта из списка истории изменений откатываются результаты всех предыдущих (расположенных выше по списку) операций.

Количество операций, которые можно отменить, задаётся в настройках программы. По умолчанию это значение равно 32.

Представления

Представления - это уникальная технология автоматической группировки изображений. Подробности - в разделе Работа с представлениями.

См. также:

Сочетания клавиш и управление мышью
Режим просмотра
Работа в режиме просмотра


Работа с представлениями

Введение

Представления фотоальбома выглядят аналогично дереву групп фотоальбома, с тем только отличием, что список групп Вы создаёте сами, а иерархия папок представления создаётся автоматически на основе данных изображений и указанных Вами группировок. Группировка является логической единицей организации представления, и она может формировать один или несколько уровней дерева папок. При построении иерархии папок представления каждое изображение попадает в какую-либо папку. В какую именно - это и определяется свойствами представления, их мы и рассмотрим более подробно далее.

Свойства представления

Как можно увидеть в окне свойств представления, представление имеет наименование, список группировок и список сортировок.

Наименование представления

Наименование задаётся Вами и может отражать содержимое представления, например, "По месту и дате".

Список группировок

На списке группировок необходимо остановиться подробнее. PhoA поддерживает следующие виды группировок:

  • По пути к файлу изображения
    Изображения раскладываются по папкам согласно их физическому расположению на диске
  • По году даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым годом. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По месяцу даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым месяцем. Обычно имеет смысл применять эту группировку после группировки по году даты, тогда в папке каждого года будут папки с месяцами этого года; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковым месяцем, но разных годов. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По дню даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым числом месяца. Обычно имеет смысл применять эту группировку после группировки по году даты и по месяцу даты, тогда в папке каждого года будут папки с месяцами этого года, а в них - папки с днями месяца; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковым числом, но разных годов и месяцев. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По часу времени
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым часом (взятым из времени изображения). Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По минуте времени
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковой минутой (взятой из времени изображения). Обычно имеет смысл применять эту группировку после группировки по часу времени, тогда в папке каждого часа будут папки с минутами этого часа; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковой минутой, но разного часа. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По месту
    Изображения организуются в папки по местам. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По номеру плёнки
    Изображения заносятся в папки по номерам плёнок. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По автору
    Изображения организуются в папки по авторам. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По наименованию/коду носителя
    Изображения организуются в папки по наименованию/коду носителя. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку
  • По ключевым словам
    Изображения организуются в папки по ключевым словам. Соответственно, одно изображение может находиться в нескольких папках, и оно будет в них находиться, если в нём указано несколько ключевых слов. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку

Список сортировок

После того, как изображения сгруппированы по папкам, они там расположены, как правило, хаотически, что не всегда приятно; тем более если учесть, что не существует способа повлиять на порядок следования изображений в группе представления. С целью устранить эту несправедливость в PhoA есть возможность отсортировать результаты группировки в каждой группе с помощью списка сортировок. Делается это в точности так же, как задаётся сортировка изображений в группах.

Помещение неклассифицированных изображений в отдельную папку

Как известно, Вы не обязаны заполнять все данные изображения, оставляя некоторые поля пустыми. Но в таком случае, поскольку при построении представления каждое изображение обрабатывается и присутствует в нём (см. выше), есть два варианта, как поступать с изображениями, не имеющими нужных сведений (даты при группировке по дате, места при группировке по месту и т.п.):

  • Если у конкретной группировки включен флажок "Неклассифицированные изображения в отдельной папке", то программа создаст соответствующую папку ("Без даты", "Без места") на том же уровне дерева, что и остальные папки, причём в самом начале уровня, и поместит туда такие изображения.
  • Если флажок не включен, то изображения без соответствующих данных остануться лежать в той же папке, что и были, никаких отдельных папок для них не создаётся. Если, скажем, после группировки по дате (с отключенным флажком) изображение так и осталось лежать в корневой папке (в папке, соответствующей самому представлению), то, если применить после этого группировку по месту (с включенным флажком), папка "Без места" будет создана в корневом каталоге, и изображение попадёт туда, а все остальные папки (с местами) будут созданы в папках дат; таким образом, классификация изображений по месту будет находиться на разных уровнях дерева папок.

Эта функция, естественно, неприменима при группировке по пути к файлу изображения, поскольку изображений без файлов, а файлов без путей не бывает (я таких, во всяком случае, не встречал).

Копирование папок представления в фотоальбом

В PhoA есть возможность скопировать полученную структуру папок и изображений в виде обычных групп фотоальбома. Для этого нужно выбрать пункт меню Вид | Представления | Поместить в группу..., при этом появится окно выбора группы, в которую нужно поместить иерархию папок представления.

См. также:

Окно свойств представления
Режим обзора
Работа в режиме обзора
Сочетания клавиш и управление мышью
Работа в режиме просмотра


Автозаполнение свойств изображений

PhoA может автоматически заполнять некоторые свойства добавляемых изображений. На текущий момент возможности автозаполнения таковы:
Свойство Возможность автозаполнения
Дата
  • Из EXIF-тега Original date & time (оригинальные дата и время)
  • Из EXIF-тега Dititized date & time (дата и время оцифровки изображения)
  • Из EXIF-тега Date & time (дата и время последней модификации изображения)
  • Извлечение из имени файла - если имя файла в формате yyyy-mm-dd hh-mm-ss.*
  • Из даты/времени создания файла
  • Из даты/времени изменения файла
Время
  • Из EXIF-тега Original date & time (оригинальные дата и время)
  • Из EXIF-тега Dititized date & time (дата и время оцифровки изображения)
  • Из EXIF-тега Date & time (дата и время последней модификации изображения)
  • Извлечение из имени файла - если имя файла в формате yyyy-mm-dd hh-mm-ss.*
  • Из даты/времени создания файла
  • Из даты/времени изменения файла

Программа пытается заполнить конкретное свойство изображения, перебирая разрешённые в настройках варианты в том порядке, в котором они перечислены. Если свойство было успешно заполнено, перебор на этом заканчивается.

Кроме того, на поведение автозаполнения влияет и опция Переписывать свойство, если оно уже указано.

См. также:

Настройки программы :: Диалоги
Данные изображений
Метаданные
Просмотр метаданных изображений


Режим просмотра

Этот режим позволяет просматривать отдельные изображения - в отдельном окне или на полном экране. Это, собственно, и является целью того, ради чего стоит составлять фотоальбом.

В режиме просмотра доступны следующие функции:

  • масштабирование (увеличение и уменьшение) изображения;
  • масштабирование изображения до величины, позволяющей вписать его целиком в окно;
  • отмена масштабирования (просмотр в масштабе 1:1);
  • прокрутка изображения мышью или клавишами, если оно не помещается целиком на экране;
  • переход к следующему, предыдущему, первому и последнему изображению в текущей группе;
  • переключение из оконного в полноэкранный режим и обратно;
  • обновление (перечитывание) файла изображения;
  • изменение текущего изображения;
  • включение/выключение режима показа слайдов;
  • вызов настроек программы и т. д.

Эти функции доступны через кнопки панели инсрументов, через контекстное меню, вызываемое нажатием правой кнопки мыши, а также через команды клавиатуры и мыши.

См. также:

Работа в режиме просмотра
Настройки программы :: Режим просмотра
Режим обзора


Работа в режиме просмотра

Поведение программы в режиме просмотра полностью определяется настройками просмотра. Некоторые из параметров настройки можно переопределять в текущем сеансе просмотра. Так, можно переключаться из оконного режима в полноэкранный нажатием клавиши F или средней клавиши мыши. В оконном режиме настройки определяют, увеличивать ли изображение до размеров окна, если оно меньше их, и наоборот, сжимать ли изображение, если оно не вписывается в окно; остаётся ли окно просмотра всегда поверх других окон; для обоих режимов также задаётся цвет незакрытой изображением части окна.

Кроме этого, PhoA может выводить при просмотре информацию о текущем изображении (а иначе зачем она нужна?)

Вы можете увеличивать и уменьшать просматриваемое изображение с помощью колёсика мыши (удерживая Ctrl) или клавишами +, -, *, / цифровой клавиатуры. Если изображение не вписывается в окно просмотра, его можно передвигать, перетаскивая мышью или клавишами со стрелками (также в сочетании с клавишами Ctrl и Shift). Более подробная информация об использовании клавиатуры и мыши в режиме просмотра содержится здесь.

NB: Максимальное увеличение изображения в данной версии PhoA составляет 8.


Окно свойств фотоальбома

Это диалоговое окно позволяет задать параметры эскизов, которые будут использоваться в фотоальбоме - размер (ширина и высота в пикселах) и качество. Размеры эскизов по умолчанию - 150х150 пиксел, качество - 40% от полного. Увеличение размеров и качества эскизов приводит к увеличению файла фотоальбома (*.phoa), и наоборот. При слишком низком качестве эскиз будет трудно узнаваем (происходит искажение цветов).

Также здесь можно ввести текстовое описание фотоальбома, которое будет сохранено в файле.

NB: Длина описания не ограничена, но не рекомендуется делать описания свыше 80 печатных страниц - будет неудобно их читать.

Эта операция поддерживает откат

См. также:

Режим обзора
Настройки программы :: Режим обзора


Мастер добавления изображения

Этот мастер служит для добавления изображений в текущую группу (в том числе в корневую, т. е. в сам фотоальбом). Если текущая группа не выбрана, эта функция недоступна.

Страница 1. Выбор файлов и папок

Добавление изображения начинается с выбора файлов изображений и/или папок, содержащих файлы изображений.

Список файлов и папок

Вы должны выделить необходимые элементы в дереве файлов клавиатурой или мышью с помощью клавиш Shift и Ctrl.

Загружать папки вместе с подпапками

Если в дереве выделены папки, то при включенном переключателе выбираются файлы не только из них, но и файлы из всех вложенных папок.

Дополнительно

Отображает/скрывает панель Фильтра выбора файлов, позволяющего наложить дополнительные условия на выбираемые файлы (см. далее).

Наличие файлов в фотоальбоме

Позволяет отсеять файлы по их присутствию в фотоальбоме:

  • Не учитывать - фильтр отключен.
  • Только файлы, отсутствующие в фотоальбоме - будут добавлены только те файлы, которые не фигурируют в общем списке изображений альбома.
  • Только файлы, присутствующие в фотоальбоме - в группу добавятся только те файлы, которые уже есть в фотоальбоме.

Маски файлов

Фильтр, ограничивающий добавляемые файлы по их имени и/или расширению. Маска строится по стандартным правилам, где символ ? заменяет любой символ, символ * - любое количество любых символов; кроме того, можно указывать наборы символов в квадратных скобках, аналогично маске при поиске.

Масок можно указывать несколько, разделяя их символом точки с запятой. Тогда соответствующими фильтру будут считаться файлы, удовлетворяющие любой маске.

Время записи файла

Здесь можно указать границы даты и/или времени модификации файла. Таким образом, например, можно выбрать файлы, сохранённые ранее или позже заданной даты. Незаполненное поле означает неактивность фильтра.

Страница 2. Выбор добавляемых файлов

На этой странице Вы можете выбрать конкретные файлы из числа выбранных на предыдущей странице, проставив у них символ отметки. По умолчанию отмеченными являются все файлы.

Отметка переключается мышью или клавишей Пробел (в последнем случае инвертируется состояние отметки у всех выделенных файлов). Контекстное меню (вызываемое правой клавишей мыши) предоставляет дополнительные опции.

NB: Эта страница отображается при установках по умолчанию. Вы можете отключить показ данной страницы в настройках диалогов, в этом случае страница будет пропускаться, и после выбора каталогов программа будет непосредственно начинать процесс добавления изображений.

Страница 3. Добавление изображений

Эта страница отображается в процессе добавления файлов изображений. Программа показывает прогресс добавления изображений и количество произошедших при добавлении сбоев. Впоследствии эти сбои (а также отчёт о добавленных успешно изображениях) можно посмотреть на странице протокола.

Кроме того, программа отображает и созданный эскиз только что добавленного изображения.

NB:
  • Добавление изображений производится в параллельном потоке; прервать процесс добавления можно только в промежутке между обработкой изображений, это слегка замедляет реакцию на нажатие кнопки Прервать.
  • Кроме того, Вы не можете закрыть окно Мастера добавления изображений, пока активен процесс добавления изображений. Для этого необходимо сначала остановить добавление нажатием кнопки Прервать.
  • Процесс добавления изображения включает автозаполнение свойств изображения. Настраивается автозаполнение в настройках диалогов; его результаты можно посмотреть в протоколе добавления изображений.

Прервать

Нажатием этой кнопки Вы можете приостановить процесс добавления. Кнопка превращается в кнопку Продолжить, нажав которую, можно возобновить процесс.

По завершении процесса добавления программа либо закрывает окно Мастера (только если не было сбоев и в настройках указано не отображать протокол при их отсутствии), либо переходит к странице протокола.

Страница 4. Протокол добавления

Здесь отображаются последовательно все операции, произведённые с файлами изображений. Каждый файл из числа выбранных для добавления либо помечается как успешно добавленный, либо его запись содержит текст произошедшей ошибки. Кроме того, в первом случае присутствует информация о результатах автозаполнения свойств изображения.

Отображать только ошибки

Если этот переключатель включен, список протокола отображает только сбойные файлы, в противном случае показываются также успешно добавленные изображения. Включить фильтрацию полезно в случае, если добавлялось множество файлов, из которых только немногие дали сбои (надеюсь, так в большинстве случаев и будет).

Сохранить в файл...

Позволяет записать протокол в простой текстовый файл, полезный, например, для последующего просмотра или машинной обработки.

NB:
  • При сохранении протокола сохраняются всегда все имеющиеся записи независимо от состояния переключателя Отображать только ошибки.
  • Сбойные записи в протоколе всегда имеют в начале строки последовательность символов [!], в то время как успешно добавленные начинаются с символов [+]. Это позволяет легко искать, скажем, ошибки в протоколе (если только у вас нет обыкновения включать в имена файлов эти последовательности символов).

Вы можете просмотреть протокол до завершения добавления всех файлов, прервав процесс добавления и нажав кнопку Далее. После этого можно (нажав Назад) вернуться к странице добавления и продолжить процесс.

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображений

Это окно служит для просмотра и редактирования свойств выделенных изображений. Чтобы отобразить его, выделите одно или несколько изображений в окне эскизов и выберите команду меню Правка | Изменить... или нажмите комбинацию клавиш Alt+Enter, когда окно эскизов имеет фокус ввода.

В окне представлены несколько страниц, переключаемых с помощью панели кнопок в левой части диалога, или нажатием комбинаций клавиш Ctrl+Цифра:
Страница | Комбинация клавиш | Назначение
Свойства файла | Ctrl+1 | Просмотр общих сведений о файлах изображений
Метаданные | Ctrl+2 | Просмотр метаданных, содержащихся в файлах изображений
Просмотр | Ctrl+3 | Просмотр самих изображений в выбранном масштабе
Данные | Ctrl+4 | Просмотр или редактирование данных изображений
Ключевые слова | Ctrl+5 | Просмотр или редактирование ключевых слов изображений
Группы | Ctrl+6 | Определение или изменение принадлежности изображений к группам

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Свойства файла

Здесь отображается список файлов выделенных изображений. Раскрыв имя файла, вы можете просмотреть его свойства (тип, размеры, время создания, записи и доступа и т.д.).

Нажатием правой кнопки мыши здесь Вы можете вызвать стандартное контекстное меню Проводника для файла.

NB: Вы можете указать в настройках диалогов сразу разворачивать свойства для всего списка файлов.

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Метаданные

Эта страница отображает метаданные, содержащиеся в файлах изображений. Метаданные выводятся для каждого файла изображения, вы можете просмотреть их, раскрыв имя файла.

Если файл не содержит метаданных, напротив его имени выводится соответствующая информация.

Нижняя панель, Описание, отображает дополнительную информацию о выбранном метатеге. Эта панель видима по умолчанию, но может быть скрыта, если нажать кнопку X на ней. Чтобы вновь отобразить эту панель, выберите соответствующий пункт из контекстного меню.

NB:
  • Вы можете указать в настройках диалогов сразу разворачивать метаданные для всего списка файлов.
  • Метаданные могут быть использованы для автозаполнения свойств изображений при добавлении их в фотоальбом. Указывается это также в настройках диалогов.
  • Названия метатегов не локализованы и приводятся на английском языке. Связано это с тем, что их шибко много :) и, кроме того, они постоянно добавляются. Кому нужно, тот разберётся.
  • Описания метатегов также не локализованы.

См. также:

Метаданные
Режим обзора
Работа в режиме обзора
Автозаполнение свойств изображений


Окно свойств изображения :: Просмотр

Здесь вы можете просмотреть любое из выделенных изображений в выбранном масштабе. Файл изображения (если изображений несколько) выбирается из выпадающего списка в верхней части страницы.

Увеличить

Увеличивает изображение на величину, указанную в настройках просмотра.

Уменьшить

Уменьшает изображение на величину, указанную в настройках просмотра.

Масштаб 1:1

Отображает изображение в масштабе 1:1 (когда каждый пиксел изображения соответствует одному пикселу на экране).

В размер окна

Масштабирует изображение так, чтобы оно точно вписалось в окно. Это режим по умолчанию.

NB: Эти команды доступны также из контекстного меню, вызываемого нажатием правой кнопки мыши.

Панорамирование изображения (если оно не вписывается в окно) осуществляется перетаскиванием его мышью. Кроме того, колёсико мыши также может использоваться для масштабирования изображения.

NB: Для ускорения отображения в качестве фильтра ресэмплинга здесь всегда используется Nearest neighbor.

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Данные

Данные изображений

Эта страница диалога свойств позволяет поменять основную часть изменяемых данных изображений:

  • Дату - дата изображения. Формат даты определяется региональными настройками Windows. Если данных о дате изображения нет, это поле не заполнено.
  • Время - время изображения. Если данных о времени нет, оставьте поле пустым.
  • Место - место изображённых событий. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Номер/название плёнки - номер, присвоенный плёнке при проявке, или данное ей Вами название. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Номер кадра - без комментариев.
  • Автор - имя автора или фотографа. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Описание - краткое описание изображения, используемое для отображения при просмотре.
  • Примечание - все данные, не попавшие в остальные поля.
  • Наименование/код носителя - название носителя, на котором расположен файл изображения (например, номер компакт-диска). Выпадающий список отображает все имеющиеся в фотоальбоме варианты.

Более подробная информация о данных изображения находится здесь.

Несколько изображений

PhoA поддерживает редактирование данных для любого числа изображений одновременно. Если говорить о текущей странице, то здесь используется незамысловатая схема обозначения свойств:

  • Если какое-то свойство совпадает у всех выделенных изображений, соответствующее поле ввода будет белого цвета (точнее, цвета окна в Windows).
  • Если значения определённого свойства различаются у разных изображений, соответствующее поле закрашивается в серый цвет (а точнее, в цвет рельефных объектов Windows). Если Вы начнёте изменять данные в этом поле, то у всех выделенных изображений соответствующее свойство примет введённое Вами значение, и поле ввода перекрасится в белый цвет. В противном случае эти данные останутся неизменными (и, соответственно, различными).

Впоследствии по введённым Вами данным можно осуществлять поиск и выборку изображений, поэтому ответственно относитесь к тому, чего вы там вводите.

Эта операция поддерживает откат

См. также:

Данные изображений
Автозаполнение свойств изображений
Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Ключевые слова

Каждое изображение имеет среди прочих своих данных список ключевых слов, описывающих его содержимое. Чаще всего это список людей, предметов или событий, изображённых на фотографии, но это могут быть и любые другие слова, которые приходят Вам на ум, когда Вы созерцаете сие изображение (соответственно, определяется словарным запасом :)

Преимущество ключевых слов перед простым текстом состоит в том, что их не обязательно набирать вслепую - их можно выбрать из списка. Кроме того, по ним можно построить представление и наблюдать, как, например, меняется их тематика от года к году (весьма интересное наблюдение, кстати). И ещё: по списку ключевых слов сразу видно, в скольких изображениях оно участвует.

Список ключевых слов

Этот список представляет собой перечень всех ключевых слов, встречающихся в изображениях текущего фотоальбома. Серым цветом в скобках после слова выводится общее количество вхождений слова в изображения (поскольку каждое слово может быть использовано в изображении только единожды, то это число представляет собой количество изображений, это слово содержащих).

Если ключевое слово содержится в каких-то из выделенных изображений, то у слова будет проставлен знак отметки (галка, если слово есть во всех выделенных изображениях и серая галка или квадратик, в зависимости от стиля переключателей, если есть, но не во всех), а в скобках после слова будет написано два числа через слэш: первое показывает, в скольких изображениях из числа выделенных это ключевое слово используется, а второе - как обычно, общее число вхождений слова в изображениях фотоальбома.

Соответственно, если ключевое слово в выделенных изображениях не присутствует, отметки у него нет.

Поскольку сравнение ключевых слов всегда регистронезависимо, программа не различает слова баня и БаНя.

На данной странице Вы можете добавлять ключевые слова. Чтобы отличить вновь добавленные слова от уже имеющихся, они выглядят по-разному:

  • Встречающиеся в фотоальбоме ключевые слова имеют значок ключика и пишутся шрифтом чёрного цвета.
  • Вновь добавленные слова имеют значок звёздочки (или как эту краказяблу назвать) и пишутся синим.

Операции с ключевыми словами

С помощью этой страницы вы можете свободно модифицировать список ключевых слов выделенных изображений. Для этого используются кнопки панели инструментов, расположенной в верхней части страницы.

NB: Эти же операции доступны через контекстное меню, вызываемое нажатием правой кнопки мыши на списке.

Только отмеченные

Если включено (кнопка нажата), в списке отображаются только те слова, которые имеют символ отметки, иначе отображаются все слова. Этот переключатель влияет только на отображение ключевых слов, и никак не влияет на сам их список.

Добавить

Добавляет новое ключевое слово в список, проставляет у него отметку и переходит в режим редактирования его. Если отметка не будет убрана, при нажатии ОК ключевое слово добавится во все выделенные изображения.

Изменить

Входит в режим редактирования ключевого слова. Нюансы:

  • Ключевое слово изменится только в тех изображениях, в которых оно было.
  • Если ключевого слова не было в выделенных изображениях (не было отметки у ключевого слова), то оно не изменится нигде.
  • Если состояние отметки изменяется в сторону включения (например, с неполной на полную), то новое слово добавится в изображения, где не было старого слова.
  • Если отметка выключается, то старое слово просто будет удалено из изображений (естественно, из числа выделенных), в которых оно было.
NB: В режим редактирования слова можно также войти, повторно нажав мышью на выделенном слове.

Отметить все

Проставляет отметку всем ключевым словам в списке (т. е. после этого все выделенные изображения будут иметь все вхождения ключевых слов).

Снять со всех

Удаляет отметку у всех ключевых слов в списке (выделенные изображения не будут иметь ключевых слов вообще).

Инвертировать

Переключает состояние отметки ключевых слов на противоположное.

NB: Почему нет кнопки удалить? Специально, чтобы не вносить двусмысленности. Если вы хотите удалить ключевое слово из изображений, снимите с него отметку.

Эта операция поддерживает откат

См. также:

Данные изображений
Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Группы

На этой странице Вы можете наглядно увидеть, в каких группах присутствуют изображения. Кроме того, здесь можно оперативно добавить изображения во множество групп, или удалить их из нескольких групп.

Аналогично ключевым словам, изменения здесь вносятся простановкой отметки у элементов списка, и аналогично им же напротив элементов выводятся числа в скобках: если число одно - оно показывает количество изображений в группе; если два (через слэш), то первое означает количество изображений в данной группе из числа выделенных, а второе - уже общее количество изображений в ней.

Аналогично ведёт себя здесь и отметка - если ни одно из выделенных изображений не содержится в конкретной группе, то отметки у неё нет. Если часть выделенных изображений содержится, а часть нет - отметка будет неполной. И если все выделенные изображения входят в эту группу, отметка будет полной.

Далее Вы можете развивать этот сюжет по своему усмотрению.

NB: Вы не можете проставить отметки так, чтобы какие-то изображения совсем перестали числиться в группах - для этого нужно было бы их (изображения) просто удалить, а удаление изображений - этот совсем другая операция. Поэтому PhoA не даст Вам внести такие изменения, предупредив соответствующим сообщением.

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно сортировки изображений

Данная функция позволяет изменить порядок следования изображений в текущей группе или во всех группах фотоальбома на основе их данных.

Если текущая группа не выбрана, то сортировка может быть произведена только по всем группам фотоальбома.

Список критериев сортировки

Порядок сортировки определяется критериями, которых можно указывать произвольное количество.

Каждый критерий в списке представляет из себя свойство изображения и направление сортировки (по возрастанию / по убыванию). Добавляются критерии автоматически, когда вы из выпадающего списка выбираете свойство, по которому нужно сортировать.

Чтобы отобразить список, нажмите мышью кнопку в первом столбце или клавишу Пробел, когда подсвечен первый столбец.

Чтобы переключить направление сортировки, нажмите мышью индикатор направления или клавишу Пробел, когда подсвечен второй столбец.

Вы также можете менять порядок элементов в списке, перетаскивая их мышью или с помощью комбинаций клавиш Ctrl+Вверх и Ctrl+Вниз.

Сброс

Возвращает установки критериев сортировки к первоначальным.

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно перестройки эскизов

Перестройка эскизов требуется прежде всего тогда, когда меняются параметры эскизов (определяемые в свойствах альбома): размеры или качество. В этом случае необходимо построить новые эскизы - в соответствии с новыми параметрами. Также эта функция может оказаться полезной, если изменились исходные изображения альбома.

Функция перестройки эскизов позволяет пересоздать эскизы в трёх вариантах:

  • для всех выделенных изображений - эскизы пересоздаются только у тех изображений которые выделены в правом окне PhoA;
  • для всех изображений текущей группы - эскизы пересоздаются у всех изображений группы, выделенной в дереве групп PhoA;
  • для всех изображений альбома - пересоздаются все эскизы.

В процессе перестройки отображается ход работы, пересоздание эскизов можно прервать в любой момент.

См. также:

Мастер добавления изображения
Окно изменения изображения


Окно операций с изображениями

Функция позволяет произвести несколько операций между выделенными изображениями и одной из групп (кроме текущей) фотоальбома. Эти операции включают:

  • Перемещение выделенных изображений в выбранную группу (аналог простого перетаскивания выделенных изображений мышью в эту группу);
  • Добавление (копирование) выделенных изображений к выбранной группе (аналог перетаскивания выделенных изображений мышью в эту группу с нажатой клавишей Ctrl);
  • Удаление выделенных изображений из выбранной группы (группа будет содержать все прежние изображения, кроме копий выделенных изображений);
  • Пересечение выделенных изображений с изображениями выбранной группы (группа будет содержать только те изображения, которые идентичны выделенным).

Это позволяет выполнять различные задачи при упорядочивании содержимого фотоальбома (например, можно убрать повторяющиеся изображения из другой группы или скопировать часть изображений из одной группы в другую).

Эта операция поддерживает откат

См. также:

Сочетания клавиш и управление мышью
Работа в режиме обзора


Статистика фотоальбома

Функция подсчёта статистики фотоальбома формирует сводные данные по изображениям и группам и отображает их.

Основные пункты статистики фотоальбома:
Название | Описание
Файл фотоальбома | Свойства файла фотоальбома, представляются аналогично свойствам файлов изображений. Кроме того, присутствует пункт Версия файла фотоальбома, отображающий версию загруженного файла.
Количество различных изображений | Количество различных изображений в фотоальбоме.
Количество вложенных групп | Количество групп, входящих в фотоальбом.
Количество изображений в группе | Количество изображений непосредственно в фотоальбоме (корневом элементе дерева групп).
Общее количество изображений | Общее количество ссылок на изображения (необязательно различные) в группе-фотоальбоме и всех вложенных группах.
Общее количество различных изображений | Общее количество ссылок на различные изображения в группе-фотоальбоме и всех вложенных группах.
Суммарный размер файлов изображений | Сумма размеров файлов изображений, входящих в группу-фотоальбом и во вложенные группы.
Средний размер файла изображения | Средний размер файла изображения из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Суммарный размер эскизов | Сумма размеров данных эскизов изображений, входящих в группу-фотоальбом и во вложенные группы.
Средний размер эскиза | Средний размер данных эскиза изображения из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Самый большой файл изображения | Имя файла изображения, имеющего самый большой размер, из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Размер самого большого файла | Размер файла изображения из предыдущего пункта.
Самый маленький файл изображения | Имя файла изображения, имеющего самый маленький размер, из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Размер самого маленького файла | Размер файла изображения из предыдущего пункта.

Если в дереве групп выделена какая-то группа, то далее дополнительно приводятся вышеперечисленные данные (кроме имени файла и числа изображений в фотоальбоме) и относительно этой группы.

См. также:

Режим обзора
Работа в режиме обзора


Окно поиска изображений

Программа PhoA обладает достаточно мощным средством выборки изображений. Для отображения окна поиска необходимо выбрать пункт меню Сервис | Поиск... или нажать клавишу F3 в режиме обзора.

Список критериев поиска

Вы вводите условия поиска в таблице критериев, которые определяются следующими данными:

  • Свойство изображения - один из поисковых элементов данных изображения, для которого вводится критерий.
  • Условие критерия - одно из условий сравнения свойства, набор возможных условий определяется типом данных.
  • Значение критерия - значение, с которым сравнивается свойство изображения.

Чтобы передвигаться по ячейкам таблицы, используются клавиши со стрелками. Для раскрытия выпадающего списка существует комбинация клавиш Alt+Вниз.

Значения условий хранят историю вводимых Вами значений.

Найти

Запускает поиск изображений.

Выбранные в результате поиска изображения (если они есть) попадают в папку Результаты поиска, которая отображается в корневом каталоге дерева групп. Для папки результатов поиска доступны те же операции, что и для всех групп изображений, за исключением добавления и удаления из неё изображений.

Сброс

Эта кнопка очищает все поля ввода и приводит все параметры к первоначальному виду.

Типы данных изображений

Согласно таблице данных изображения, PhoA использует следующие типы данных в свойствах изображений:
Тип данных | Описание и критерии
Целое или натуральное число | Данные представляют собой обычное целое число, которое можно проверить на равенство, неравенство и т. д.
Строка-имя файла | Данные могут быть проверены на соответствие маске. Маска составляется по обычным правилам файловой системы: ? - любой символ, * - любое количество любых символов; кроме этого, Вы можете указывать диапазон значений символов в квадратных скобках, например, [A-Z].
Строка | Любые символьные данные. Поиск по строке или подстроке в любых вариантах. Поиск регистронезависим.
Пиксельный формат | Не является поисковым типом.
Дата | Данные проверяются по критериям, аналогичным тем, что используются у чисел.
Время | Данные проверяются по критериям, аналогичным тем, что используются у чисел.
Список строк | Это список ключевых слов. Слова можно вводить вручную или нажать кнопку "..." в поле ввода для выбора ключевых слов из списка. Критерии включают условия присутствия и отсутствия заданных (или всех) слов.

Программа выбирает те изображения, которые соответствуют всем критериям поиска одновременно (то есть здесь действует условие И).

Чтобы отключить какой-либо критерий, удалите его значение.

См. также:

Данные изображений
Работа в режиме обзора
Сочетания клавиш и управление мышью
Мастер добавления изображения
Окно изменения изображения


Окно выбора ключевых слов

Окно появляется при вызове списка ключевых слов из окна поиска. Программа составляет список всех ключевых слов, использованных в изображениях, и выводит их в алфавитном порядке. Числа в скобках после ключевых слов обозначают количество вхождений слов в изображения фотоальбома.

Вы можете отметить те ключевые слова, по которым нужно провести поиск.

Сброс

Снимает отметку со всех пунктов.

NB: Если ключевое слово содержит символы пробела или запятой, при подстановке оно автоматически берётся в двойные кавычки, поскольку эти символы являются разделителями списка слов.

См. также:

Поиск изображений
Ключевые слова изображений
Данные изображений


Окно свойств представления

Это окно служит для добавления или изменения свойств представления.

Наименование служит для того, чтобы можно было понять назначение представления; списки группировок и сортировок определяют алгоритм построения представления.

Более подробно о представлениях рассказано здесь.

См. также:

Работа в режиме обзора


Окно выбора группы фотоальбома (для помещения представления)

Это окно служит для указания, в какую из групп фотоальбома необходимо поместить иерархию папок, сформированную представлением:

Вся структура папок и изображений представления будет скопирована в указанную группу фотоальбома (в качестве неё можно указать и сам фотоальбом). Далее Вы можете производить необходимые операции с полученными группами и изображениями, как обычно.

См. также:

Работа с представлениями
Работа в режиме обзора


Сочетания клавиш и управление мышью

Программа PhoA позволяет выполнить практически любое действие несколькими способами: выбором пункта основного меню или нажатием кнопки на панели инструментов (только в режиме обзора), нажатием сочетания клавиш на клавиатуре, выбором пункта из контекстного меню или соответствующей операцией с мышью. Ниже приводятся сочетания клавиш и управление мышью для основных режимов работы программы: для режима обзора, для режима просмотра.

Режим обзора

Клавиатура

Клавиши | Действие | Описание
Ctrl+N | Создание нового фотоальбома | Очищает всю информацию о фотоальбоме, группах и изображениях.
Ctrl+O | Открытие файла фотоальбома | Открывает окно для выбора файла фотоальбома, загружает фотоальбом для обработки или просмотра.
Ctrl+S | Сохранение файла фотоальбома | Записывает текущий фотоальбом в файл на диске.
F12 | Сохранение фотоальбома в файл с другим именем | Открывает окно для ввода имени нового файла фотоальбома, записывает фотоальбом в выбранный файл и делает этот файл текущим.
Alt+Ins | Создание группы | Создаёт новую группу в текущей группе, присваивает ей имя по умолчанию и входит в режим редактирования имени.
Ins | Добавление изображения | Открывает Мастер добавления изображения (или нескольких изображений) в текущую группу.
Del | Удаление | Удаляет выбранную группу или выделенные изображения после выдачи запроса (зависит от текущего выделения).
Ctrl+Z, Alt+Backspace | Отменить | Отменяет последнее сделанное Вами изменение.
Ctrl+X, Shift+Del | Вырезать | Удаляет выделенные изображения в буфер обмена (можно впоследствии добавить вырезанные изображения к другой группе).
Ctrl+C, Ctrl+Ins | Копировать | Копирует выделенные изображения в буфер обмена (можно впоследствии добавить скопированные изображения к другой группе).
Ctrl+V, Shift+Ins | Вставить | Добавляет изображения из буфера обмена к текущей группе (если буфер обмена содержит изображения, помещённые туда программой PhoA).
Alt+Enter | Изменение | Открывает окно свойств фотоальбома или изображения, или переходит в режим редактирования имени текущей группы (зависит от текущего выделения).
Ctrl+F3 | Сортировка изображений | Открывает окно сортировки изображений.
Ctrl+A | Выделить все | Выделяет все изображения текущей группы.
Ctrl+D | Снять выделение | Убирает выделение со всех изображений текущей группы.
Ctrl+Enter | Просмотр | Переходит в режим просмотра текущего изображения.
F4 | Настройки программы | Открывает окно настроек программы.
F8 | Статистика | Выдаёт статистику фотоальбома.
Ctrl+R | Перестройка эскизов | Открывает окно перестройки эскизов.
Ctrl+F2 | Операции с изображениями | Вызывает диалоговое окно операций с изображениями.
F3 | Поиск | Доступ к функции поиска изображений.
Ctrl+F1 | О программе | Отображает информацию о версии, авторских правах и обновлении PhoA.
F1 | Содержание справки | Запускает Справочную систему PhoA.
Клавиши со стрелками | Перемещение выделения | Перемещает выделение по дереву групп или списку изображений (в зависимости от того, какое окно активно).
Home, Ctrl+Page Up | Первый элемент | Перемещает выделение к первой группе или изображению (в зависимости от того, какое окно активно).
End, Ctrl+Page Down | Последний элемент | Перемещает выделение к последней группе или изображению (в зависимости от того, какое окно активно).
Page Up | Предыдущая страница | Перемещает выделение на один экран вверх.
Page Down | Следующая страница | Перемещает выделение на один экран вниз.
Shift+Клавиши со стрелками | Выделение диапазона изображений | Выделяет подряд несколько изображений (с предыдущего до следующего текущего).
Shift+Home, Shift+Ctrl+Page Up | Выделение изображений до начала | Выделяет подряд изображения с текущего до самого первого.
Shift+End, Shift+Ctrl+Page Down | Выделение изображений до конца | Выделяет подряд изображения с текущего до самого последнего.
Shift+Page Up | Выделение изображений на страницу вверх | Выделяет подряд изображения с текущего до изображения, находящегося на один экран выше.
Shift+Page Down | Выделение изображений на страницу вниз | Выделяет подряд изображения с текущего до изображения, находящегося на один экран ниже.
Ctrl+G | Группы изображений | Отобразить дерево групп фотоальбома (в случае, если активно представление).
Shift+Alt+Ins | Новое представление | Открыть Окно добавления представления.
Shift+Alt+Del | Удалить представление | Удаляет текущее представление.
Shift+Alt+Enter | Изменить представление | Открыть окно свойств представления.
Shift+Alt+G | Поместить представление в группу | Открыть окно выбора группы для помещения в неё представления.

Мышь

Клавиши | Действие | Описание
Колёсико | Прокрутка | Прокручивает дерево групп или список изображений (в зависимости от того, какое окно активно).
Щелчок левой кнопкой | Одиночное выделение | Выделяет одну группу или изображение (в зависимости от того, какое окно активно).
Щелчок правой кнопкой | Контекстное меню | Вызывает контекстное меню.
Ctrl+Щелчок левой кнопкой | Выделение отдельных изображений | Выделяет или снимает выделение с одиночного изображения.
Shift+Щелчок левой кнопкой | Выделение диапазона изображений | Выделяет подряд несколько изображений (с предыдущего выбранного до того, на котором щёлкнули).
Нажатие левой кнопки и смещение в свободной от изображений области, Alt+Нажатие левой кнопки и смещение | Выделение прямоугольной области | Рисует рамку группового выделения изображений (в виде прямоугольника).
Shift+Alt+Нажатие левой кнопки и смещение | Добавление к выделению прямоугольной области | Дополняет текущее выделение рамкой группового выделения изображений.
Перетаскивание выделенных изображений при нажатой левой кнопке внутри окна | Упорядочивание изображений | Перемещает выделенные изображения в точку вставки.
Перетаскивание выделенных изображений при нажатой левой кнопке в одну из групп | Перемещение изображений | Перемещает выделенные изображения из текущей группы в другую группу. Отображает информацию о том, сколько реально изображений было перенесено, если это включено в настройках программы.
Ctrl+Перетаскивание выделенных изображений при нажатой левой кнопке в одну из групп | Копирование изображений | Копирует выделенные изображения в другую группу. Отображает информацию о том, сколько реально изображений было скопировано, если это включено в настройках программы.
Двойной щелчок по узлу дерева групп | Свернуть/развернуть | Сворачивает или разворачивает узел дерева.
Двойной щелчок по изображению | Режим просмотра | Перейти в режим просмотра выбранного изображения.

Режим просмотра

Клавиатура

Клавиши | Действие | Описание
Page Down, Space | Следующее изображение | Переход к просмотру следующего изображения.
Page Up, BackSpace | Предыдущее изображение | Переход к просмотру предыдущего изображения.
Home | Первое изображение | Переход к просмотру первого изображения.
End | Последнее изображение | Переход к просмотру последнего изображения.
+ (цифровая клавиатура) | Увеличить | Увеличивает изображение на величину, указанную в настройках режима просмотра.
- (цифровая клавиатура) | Уменьшить | Уменьшает изображение на величину, указанную в настройках режима просмотра.
* (цифровая клавиатура) | Наилучшее соответствие окну | Масштабирует изображение так, чтобы оно точно вписалось в окно.
/ (цифровая клавиатура) | Масштаб 1:1 | Отображает изображение в масштабе 1:1 (когда каждый пиксел изображения соответствует одному пикселу на экране).
Alt+Enter | Изменить | Открывает окно свойств текущего отображаемого изображения.
Pause | Включить/выключить показ слайдов | Активизирует или деактивизирует автоматический показ слайдов. Параметры просмотра слайдов задаются в настройках режима просмотра.
F | Полноэкранный / Оконный режим | Переключает режим отображения из полноэкранного в оконный и обратно.
F5 | Перегрузить изображение | Перечитывает текущее изображение из файла.
F4 | Настройки программы | Открывает окно настроек программы.
F1 | Справка | Отображает справку по режиму просмотра.
Enter, Esc | Завершить просмотр | Возвращает программу в режим обзора.
Клавиши со стрелками | Прокрутка изображения | Прокручивает изображение в заданном направлении (если оно не вписывается в окно).
Shift+Клавиши со стрелками | Точная прокрутка изображения | Медленно прокручивает изображение в заданном направлении (если оно не вписывается в окно).
Ctrl+Клавиши со стрелками | Быстрая прокрутка изображения | Быстро прокручивает изображение в заданном направлении (если оно не вписывается в окно).
Ctrl+I | Перемещение поля информации | Отображает маркеры вокруг строки информации, позволяющие перемещать и изменять её размер. Повторное нажатие или нажатие мышью вне поля завершает режим.

Мышь

Клавиши | Действие | Описание
Колёсико вниз | Следующее изображение | Переход к просмотру следующего изображения.
Колёсико вверх | Предыдущее изображение | Переход к просмотру предыдущего изображения.
Щелчок средней кнопкой, Щелчок колёсиком | Полноэкранный / Оконный режим | Переключает режим отображения из полноэкранного в оконный и обратно.
Щелчок правой кнопкой | Контекстное меню | Вызывает контекстное меню.
Ctrl+Колёсико вверх | Увеличить | Увеличивает изображение на величину, указанную в настройках режима просмотра.
Ctrl+Колёсико вниз | Уменьшить | Уменьшает изображение на величину, указанную в настройках режима просмотра.
Перетаскивание при нажатой левой кнопке | Прокрутка изображения | Прокручивает изображение в заданном направлении (если оно не вписывается в окно).


Настройки программы :: Общие

Интерфейс

Язык интерфейса

Язык всего интерфейса программы. Пока только русский или английский.

Шрифт программы

Базовый шрифт, используемый во всех окнах PhoA.

Продолжительность отображения всплывающих подсказок

Длительность отображения подсказок в миллисекундах.

Длина списка последних открывавшихся файлов

Количество запоминаемых имён файлов, выводимое в меню Файл и в списке кнопки Открыть...

Панели инструментов

Размер кнопок основной панели

Регулирует размер кнопок основной панели инструментов.

Перетаскивание панелей

Определяет режим перетаскивания/встраивания панелей инструментов

Деревья/списки

Анимация сворачивания/разворачивания

Если включено, операции сворачивания и разворачивания узлов дерева используют анимацию.

Панорамирование нажатием средней кнопки мыши

Если включено, при нажатии средней кнопки мыши в списке появляется индикатор панорамирования, при этом можно плавно прокручивать содержимое окна, откатив мышь в нужную сторону от этого индикатора.

Центрирование выделения

Если включено, программа будет пытаться всегда прокручивать списки так, чтобы выделенный пункт находился в центре окна списка.

Поиск при наборе текста

Если включено, выделение в списках автоматически сдвигается на узел, если вы набираете его текст.

Задержка сброса набора для поиска

Задаёт время в миллисекундах, в течение которого последовательные нажатия клавиш считаются относящимися к одному циклу поиска.

Вид кнопок сворачивания/разворачивания

Позволяет выбрать разновидность кнопок сворачивания/разворачивания узлов дерева (только на не-WindowsXP-системах).

Вид переключателей в узлах

Позволяет выбрать разновидность переключателей в узлах дерева там, где они есть (только на не-WindowsXP-системах).

Вид рамки выделения

Позволяет выбрать тип отрисовки рамки множественного выделения в списках (только на не-WindowsXP-системах).

См. также:

Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги


Настройки программы :: Режим обзора

Окно просмотра эскизов

Цвет фона

Задаёт цвет фона окна эскизов.

Drag'n'Drop

Разрешает или запрещает перетаскивание изображений из окна эскизов.

Показывать всплывающие описания эскизов

Эта функция разрешает отображать всплывающие подсказки (ToolTips), если остановить мышь над эскизом. Эти подсказки отображают свойства изображения (см. ниже). Вообще-то полезная функция, но некоторых раздражает.

Отображать во всплывающих описаниях

Список свойств, из которого Вы можете выбрать, какие свойства изображений отображать во всплывающих описаниях эскизов.

Данные, отображаемые на эскизах

С помощью этих опций Вы можете выбрать отображать ли и какие именно из свойств изображений в каждом из четырёх углов эскиза.

Чёткие границы эскиза

Когда включен, границы прямоугольников эскизов отображаются более чётко (только на не-WindowsXP-системах).

Кэшировать эскизы при просмотре

Поскольку эскизы хранятся в формате JPEG, на их отрисовку тратится существенное время (особенно, если их входит на экран сразу много, а компьютер недостаточно мощный). Поэтому предусмотрена функция кэширования декодированных эскизов после их первой отрисовки. Правда, это требует большего объёма памяти.

Размер кэша эскизов

Максимальное количество эскизов в кэше.

Метод ресэмплинга эскизов

Определяет интерполяционный фильтр, используемый при ресэмплинге (уменьшении) изображений для получения эскизов.

Количество операций в буфере отмены

Задаёт размер буфера, используемого для хранения данных для отмены операций. Вы можете отменить не более указанного количества операций подряд (при заполнении буфера удаляются данные о самых ранних операциях). Большой размер буфера может потребовать значительного объёма памяти для хранения (особенно объёмными являются операции удаления и редактирования изображений).

См. также:

Настройки программы :: Общие
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги


Настройки программы :: Режим просмотра

Окно просмотра поверх всех окон

Не позволяет окну просмотра опускаться ниже других окон, когда оно неактивно. Имеет смысл только в оконном режиме.

Полноэкранный режим

При входе в режим просмотра сразу устанавливается полноэкранный режим, когда скрываются все элементы оформления Windows (в том числе и Панель задач). При этом можно переключаться в оконный режим и обратно нажатием клавиши F или средней клавиши мыши.

Скрывать указатель мыши в полноэкранном режиме

При входе в полноэкранный режим указатель мыши скрывается (чтоб не маячил перед глазами).

Цвет фона окна просмотра

Определяет цвет незакрытых изображением частей окна просмотра. По умолчанию - чёрный.

Отображать панель инструментов

Разрешает/запрещает показ панели инструментов режима просмотра.

Смена изображений

Подгонять размер окна под размер изображения

Изменяет размер окна так, чтобы изображение при текущем выбранном масштабе целиком помещалось в нём. Имеет смысл только в оконном режиме.

Центрировать окно на рабочем столе

Помещает окно просмотра в центре рабочего стола. Имеет смысл только в оконном режиме.

Сжимать изображение до размера окна

Если изображение больше размеров окна, оно пропорционально уменьшается (так, чтобы точно вписаться в окно).

Растягивать изображение до размера окна

Если изображение меньше размеров окна, оно пропорционально растягивается (так, чтобы точно вписаться в окно).

Циклический просмотр

Если включено, после просмотра последнего изображения программа переходит к первому, и наоборот.

Предекодировать следующее изображение

Эта опция разрешает фоновое упреждающее декодирование изображений, что позволяет переходить к следующему изображению более быстро (следующее изображение декодируется во время просмотра текущего). Этот режим требует дополнительной памяти для хранения данных следующего изображения.

Кэшировать предыдущее изображение

Если опция включена, последнее просмотренное изображение не удаляется из памяти, что позволяет быстро возвращаться к предыдущему изображению. Этот режим требует дополнительной памяти для хранения данных предыдущего изображения.

Шаг изменения масштаба

Определяет, с каким шагом будет изменяться масштаб при увеличении/уменьшении изображения (клавишами + и - на цифровой клавиатуре или колёсиком мыши при нажатом Ctrl).

Отображать в заголовке окна

Позволяет выбрать свойства изображения, которые будут отображаться в заголовке окна. Имеет смысл только в оконном режиме.

Метод ресэмплинга изображения

Определяет интерполяционный фильтр, используемый при ресэмплинге (масштабировании) изображений при просмотре.

Отображаемая информация

Данные изображения

Определяет, какие свойства изображения отображаются на экране в режиме просмотра.

Шрифт

Задаёт шрифт, используемый для отрисовки описания изображения

Цвет фона

Задаёт цвет фона, на котором отрисовывается информационная строка. См. следующий параметр.

Непрозрачность фона

Значение в диапазоне от 0 (прозрачный фон, т.е. его нет) до 255 (непрозрачный фон). Позволяет задать степень прозрачности фона информационной строки.

Просмотр слайдов

Время показа изображения

Задаёт интервал времени в миллисекундах между автоматической сменой изображения в режиме показа слайдов (режим показа слайдов активизируется в режиме просмотра нажатием кнопки Pause, через панель инструментов или контекстное меню).

Циклический просмотр

Если включен, то при просмотре слайдов программа автоматически переходит к просмотру первого изображения в группе после просмотра последнего. В противном случае по достижении последнего изображения показ слайдов прекращается.

См. также:

Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Диалоги


Настройки программы :: Диалоги

Подтверждения

Перед удалением группы

Если включено, перед удалением группы выдаётся соответствующий запрос.

Перед удалением изображений

Если включено, перед удалением изображений выдаётся соответствующий запрос.

Перед удалением представления

Если включено, перед удалением представления выдаётся соответствующий запрос.

Перед сохранением файла устаревшей версии

Если включено, то при сохранении файла более старой версии, чем текущая, выдаётся предупреждение о возможной потере данных.

Перед выходом (при сохранённом фотоальбоме)

Если включено, перед выходом из программы выдаётся запрос даже при неизменённом фотоальбоме (при изменённом фотоальбоме запрос выдаётся всегда).

Уведомления

После копирования изображений с помощью Drag'n'Drop

Если включено, после копирования изображений перетаскиванием выдаётся информация о том, сколько реально изображений было скопировано.

После перемещения изображений с помощью Drag'n'Drop

Если включено, после перемещения изображений перетаскиванием выдаётся информация о том, сколько реально изображений было перенесено.

После вставки изображений из буфера обмена

Если включено, после вставки изображений из буфера обмена выдаётся информация о том, сколько реально изображений было вставлено.

Мастер добавления изображений

Пропускать страницу отметки файлов

Если включено, то после выбора файлов/папок в Мастере добавления изображений PhoA сразу начинает процесс добавления изображений.

Отображать протокол добавления только при наличии ошибок

Если включено, протокол добавления будет отображаться только в том случае, если при добавлении происходили сбои, в противном случае окно Мастера добавления закроется сразу по окончании процесса добавления изображений. Если выключено, протокол будет отображаться всегда по завершении процесса.

Автозаполнение даты изображения из:

Настраивает свойства, которые будут участвовать в автозаполнении даты изображения при добавлении.

Переписывать дату, если она уже указана

Заставляет программу производить автозаполнение даты изображения (переписывать дату), даже если дата изображения уже введена.

Автозаполнение времени изображения из:

Настраивает свойства, которые будут участвовать в автозаполнении времени изображения при добавлении.

Переписывать время, если оно уже указано

Заставляет программу производить автозаполнение времени изображения (переписывать время), даже если время изображения уже введено.

Окно свойств изображений

Сразу раскрывать свойства файлов

Если включено, свойства файлов на странице свойств раскрываются сразу полностью.

Сразу раскрывать метаданные изображений

Если включено, метаданные изображений на странице метаданных раскрываются сразу полностью.

См. также:

Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра


License Agreement

Except where otherwise explicitly noted, all of the documentation and software included in the PhoA package is copyrighted by Dmitry Kann.

Copyright ©2002-2003 Dmitry Kann. All rights reserved.

This software is provided "as-is", without any express or implied warranty. In no event shall the author be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter and redistribute it, provided that the following conditions are met:

  1. All redistributions of packaged files must retain all copyright notices that are currently in place, and this list of conditions without any modification.
  2. All new redistributions resulted in translated to any language resources of PhoA in binary form must retain all occurences of the above copyright notice and web site addresses that are currently in place (for example, in the About boxes).
  3. The origin of this software must not be misrepresented; likewise, if you use this software to distribute a functional product, an acknowledgment in the product documentation would be greatly appreciated.
  4. Modified versions must be plainly marked as such, and must not be misrepresented as being the original software.

Updates: http://phoa.narod.ru/
Contact email: phoa@narod.ru

Major Contributors

  • Jordan Russel - Toolbar2000
  • Alex Denisov - TBX & Graphics32
  • Mike Lischke - GraphicEx & VirtualTreeview
  • Jim Kueneman - VirtualShellTools